Лекція 4. Оператори вбудованої мови.

Матеріал з Фізмат Вікіпедії
Перейти до: навігація, пошук

Перелічимо основні оператори вбудованої мови 1C: Підприємство.

1. Умовний оператор.

 Если ЛогВыражение Тогда 
     //операторы; 
 [ИначеЕсли ЛогВыражение Тогда] 
    //операторы; 
 [Иначе] 
    //операторы; 
 КонецЕсли;

2. Цикли.

a) цикл з умовою

 Пока ЛогВыражение Цикл 
    //операторы; 
 КонецЦикла;


б) цикл з лічильником

 Для ПерСчетчик = Выражение1 По Выражение2 Цикл 
    //операторы; 
 КонецЦикла; 


3. Безумовна передача управління іншого оператора програми.

 Перейти ИмяМетки;


Для того щоб поставити мітку на будь-який оператор, необхідно вказати:

 ИмяМетки: оператор

Забороняється перехід на оператори Процедура і Функція, а також на оператори, що знаходяться усередині конструкцій циклів або умов. Область дії оператора Перейти обмежена програмним модулем, процедурою або функцією, в якій оператор застосований.

4. Передача управління в початок циклу (аналог оператора С + + continue).


 Продолжить;


5. Переривання виконання циклу (аналог оператора С + + break).


 Прервать;